Support page unavailable
Incident Report for Magento Business Intelligence
Resolved
This incident has been resolved.
Posted 10 months ago. Oct 22, 2016 - 16:04 UTC
Monitoring
Due to the widespread DNS issues today, our support page on Zendesk may not be available. This will result in delayed responses to support requests.
Posted 10 months ago. Oct 21, 2016 - 18:36 UTC